Missing files & meshes

36 posts / 0 new
Last post
Nakisey's picture
Nakisey
Joined:
2017-02-25 03:54
Last seen:
4 months 3 weeks ago

So I recently installed tamriel rebuilt, I even patched the files, but im still encountering errors. I don't know what else to say, ill keep looking for a solution, but to save some time ill ask for help here. 
What should I do? 

Warnings.txt:
Unable to find Region 'Sea of Ghosts Region' in Load for Cell 'Wilderness'.

Morrowind.ini:
[Archives]
Archive 0=Tribunal.bsa
Archive 1=Bloodmoon.bsa
Archive 2=PT_Data.bsa
Archive 3=TR_Data.bsa
Archive 4=Flora Glow.bsa

Thanks in advance

hobblesure's picture
hobblesure
Joined:
2017-02-26 00:44
Last seen:
4 months 5 days ago

Bump. I'm having the same problem, only mods installed are mge xe, morrowind code patch, and tamriel rebuilt. Patched all my .esm files and edited the .ini correctly.

Rot's picture
Rot
Lead DeveloperQuest Developer
Joined:
2014-03-16 17:45
Last seen:
4 days 22 hours ago

Did you install it in Program Files and do you have User Account Control turned on? It can cause issues, (unless it's a Steam version which I hear gives access and so avoids them)

Otherwise, which TR files are checked in your mod list? (Data Files in the launcher)
If you've used something that modifies or sorts dates or load orders, in what order do they appear?
Do you have any mods made for TR?

Atrayonis's picture
Atrayonis
Lead DeveloperDeveloperInterior Developer
Joined:
2015-09-28 20:13
Last seen:
7 hours 34 min ago

Unable to find Region 'Sea of Ghosts Region' in Load for Cell 'Wilderness'.  means that TR_Mainland is loading before Tamriel_Data.
The regions are defined in Tamriel_Data and if a cell has a region id that doesn't yet exist, it will produce exactly this error.

Check the dates on your files (or load order in Wrye Mash). That might also cause some of the asset problems.

MinerMan60101's picture
MinerMan60101
DeveloperExterior DeveloperInterior Developer
Joined:
2016-10-09 23:10
Last seen:
17 hours 41 min ago

This should probably be put in the FAQ, in case some people have the same problem.

Sweet_Bro99's picture
Sweet_Bro99
Joined:
2017-03-08 01:16
Last seen:
4 months 1 week ago

Hello Folks,

I am encountering a similar problem. I am only using the latest Tamriel_Data.esm, TR_Mainland.esm, TR_Preview.esm, and TR_Travels.esm. Latest Morrowind code patch also used. 

Error is: Lots of floating question marks, lots of error prompts (seems to most be meshes).

- I have updated Morrowind.ini to include the PT_Data and TR_Data bsa's. 
- I have used wrye mash to ensure load order is correct (Morrowind>Tribunal>Bloodmoon>Tamriel_Data>TR_Mainland>MorrowindPatch>TR_Preview>TR_Travels)

Possibly area causing the issue - I am not really sure how exactly to use wrye mash, and I have simply changed the various esm file dates such that they load from oldest to newest? I cant seem to find any clearly laid out tutorial on this specifically. 

I am using windows 10, and installed through Steam. However, it is important to point out that I had Tamriel rebuilt version that I downloaded in ~July of last year working just fine - this clean reinstall seems to be the issue (multiple reinstalls).

Any thoughts? Am I using wrye wrong? Am I missing something else?

Cheers,

Rot's picture
Rot
Lead DeveloperQuest Developer
Joined:
2014-03-16 17:45
Last seen:
4 days 22 hours ago

@ Sweet_Bro99 yes on wrye mash ordering, that's done by changing the dates,
Can you make sure of the following:
- both files "PT_Data.bsa" "TR_Data.bsa" are in the Data files folder,
- in "Morrowind.ini" they are included after, not before, the Tribunal and Bloodmoon BSAs

Other than that your screenshot shows the right order and checks so I don't know what could be missing. On the off-chance that the "Program Files" folder location is still causing trouble despite the Steam install, you could try copying your whole Morrowind folder elsewhere (e.g. directly on C:\) and see if meshes are still missing when launching from Morrowind.exe in that folder.

Sweet_Bro99's picture
Sweet_Bro99
Joined:
2017-03-08 01:16
Last seen:
4 months 1 week ago

PT_Data.bsa and TR_Data.bsa are both in the Data Files folder.

I've attached a screenshot of the morrowind.ini file. The load order is as seen before - however, have a look at the order shown in the ini. Does this have any bearing over load order? Or does the order seen in the launcher the actual load order? I have tried rearranging that list to a proper order, but still not working.

I tried copying the morrowind folder outside of program files, but get an error running the game (probably some appdata issue, would have to actually install it outside of program files, but steam doesn't allow that). 

Another possible avenue I will have a look around at - when I edit morrowind.ini for the first time, a prompt from steam comes up. It asks if I should upload to the cloud, or download from the cloud. I select upload, but perhaps it isn't properly saving because of how steam preserves core game files... 

Rot's picture
Rot
Lead DeveloperQuest Developer
Joined:
2014-03-16 17:45
Last seen:
4 days 22 hours ago

All is in order,
I don't think Steam is causing this, people normally seem to be able to use mods with it,

Reposting from above in case missed: are you trying to load saves from last year? If so you'll need to patch them with the "TR_FilePatcher.jar" found in the Tamriel_Data download (some cell names may still give errors)

Sweet_Bro99's picture
Sweet_Bro99
Joined:
2017-03-08 01:16
Last seen:
4 months 1 week ago

I had initially been trying on old save files, but this occurs when starting a new game as well. Have not had time to try anything else yet - may revert to old version soon and get back to playing. I seem to recall having the same issue last year, wish I wrote down how to fix it!

Rot's picture
Rot
Lead DeveloperQuest Developer
Joined:
2014-03-16 17:45
Last seen:
4 days 22 hours ago

Some people have also reported in the past that running as adminitrator (the Morrowind exe or Steam exe?) fixed similar issues, but I don't know if that's still current.

Sweet_Bro99's picture
Sweet_Bro99
Joined:
2017-03-08 01:16
Last seen:
4 months 1 week ago

Ah, finally, I figured it out.

It was regarding the Morrowind.ini file:

The tutorial outlines exactly what to write in (as you can see in my attachment above, it is correct). However, it says that [Archives] is located directly above the [Game Files], right at the bottom. If it is not located there, it says to then add it to that line (Or maybe I am crazy and hearing things). Anyway, that is what I did - but there is an [Archives] located elsewhere in the Morrowind.ini that was not getting updated (never thought to look). 

So, simple mistake on my part. Thanks for all the help.

Kinky Kong Keith's picture
Kinky Kong Keith
Joined:
2017-03-12 18:24
Last seen:
4 months 5 days ago

I'm having some issues with missing meshes/textures too, though I think it has to do with better robes. 

TES3Stream Warning: Model "Meshes\tr\c\tr_c_exp_robe_01_f.nif" tex not found "textures\TR_c_robe_expensive_MH_hole_01.dds"!
TES3Stream Warning: Model "Meshes\tr\c\tr_c_exp_robe_01_f.nif" tex not found "textures\TR_c_robe_expensive_MH_sleeve_05.dds"!
TES3Stream Warning: Model "Meshes\tr\c\tr_c_exp_robe_01_f.nif" tex not found "textures\TR_c_robe_expensive_MH_back_04.dds"!
TES3Stream Warning: Model "Meshes\tr\c\tr_c_exp_robe_01_f.nif" tex not found "textures\TR_c_robe_expensive_MH_Front_11.dds"!
Texture Load Error!: textures\TR_c_robe_expensive_MH_hole_01.dds
Texture Load Error!: textures\TR_c_robe_expensive_MH_sleeve_05.dds
Texture Load Error!: textures\TR_c_robe_expensive_MH_back_04.dds
Texture Load Error!: textures\TR_c_robe_expensive_MH_Front_11.dds
TES3Stream Warning: Model "Meshes\tr\c\tr_c_exq_robe_01_f.nif" tex not found "TR_C_Robe_exquisite_1_01.dds"!
TES3Stream Warning: Model "Meshes\tr\c\tr_c_exq_robe_01_f.nif" tex not found "TR_C_Robe_exquisite_1.dds"!
Texture Load Error!: TR_C_Robe_exquisite_1_01.dds
Texture Load Error!: TR_C_Robe_exquisite_1.dds
TES3Stream Warning: Model "Meshes\tr\c\tr_com_h_robe_aa01_f.nif" tex not found "TR_C_RobeCommon02_A_sleevehole_AA.dds"!
TES3Stream Warning: Model "Meshes\tr\c\tr_com_h_robe_aa01_f.nif" tex not found "TR_C_RobeCommon02_A_sleeve_AA.dds"!
TES3Stream Warning: Model "Meshes\tr\c\tr_com_h_robe_aa01_f.nif" tex not found "TR_C_RobeCommon02_C_upperbody_AA.dds"!
TES3Stream Warning: Model "Meshes\tr\c\tr_com_h_robe_aa01_f.nif" tex not found "TR_C_RobeCommon02_C_lowerbody_AA.dds"!
Texture Load Error!: TR_C_RobeCommon02_A_sleevehole_AA.dds
Texture Load Error!: TR_C_RobeCommon02_A_sleeve_AA.dds
Texture Load Error!: TR_C_RobeCommon02_C_upperbody_AA.dds
Texture Load Error!: TR_C_RobeCommon02_C_lowerbody_AA.dds
TES3Stream Warning: Model "Meshes\tr\c\tr_c_exp_robe_01_f.nif" tex not found "textures\TR_c_robe_expensive_MH_hole_01.dds"!
TES3Stream Warning: Model "Meshes\tr\c\tr_c_exp_robe_01_f.nif" tex not found "textures\TR_c_robe_expensive_MH_sleeve_05.dds"!
TES3Stream Warning: Model "Meshes\tr\c\tr_c_exp_robe_01_f.nif" tex not found "textures\TR_c_robe_expensive_MH_back_04.dds"!
TES3Stream Warning: Model "Meshes\tr\c\tr_c_exp_robe_01_f.nif" tex not found "textures\TR_c_robe_expensive_MH_Front_11.dds"!
Texture Load Error!: textures\TR_c_robe_expensive_MH_hole_01.dds
Texture Load Error!: textures\TR_c_robe_expensive_MH_sleeve_05.dds
Texture Load Error!: textures\TR_c_robe_expensive_MH_back_04.dds
Texture Load Error!: textures\TR_c_robe_expensive_MH_Front_11.dds

And there's this really weird problem with Tel darys where the hallway to the west part (I think) is completely missing, and if I walk into it i fall into nothingness. 

Rot's picture
Rot
Lead DeveloperQuest Developer
Joined:
2014-03-16 17:45
Last seen:
4 days 22 hours ago

@ Kinky Kong Keith  I can find the textures (at least the TR_C_RobeCommon02 ones) but it seems they're being looked for in the root folder whereas they're now in TR\c\ in TR_Data.bsa. Might be something that happened during this change on TR's end.

edit: yes, known issue with better robes. It doesn't look like an automated patcher was made for that, sorry.

Atrayonis's picture
Atrayonis
Lead DeveloperDeveloperInterior Developer
Joined:
2015-09-28 20:13
Last seen:
7 hours 34 min ago

The permissions from the author allow the posting of a fixed version. It's just that someone needs to do it.

Judging from the comments on Nexus, nobody has had the drive to download NIFScope, fire up the CS and just fix it for over a year.

Kinky Kong Keith's picture
Kinky Kong Keith
Joined:
2017-03-12 18:24
Last seen:
4 months 5 days ago

I have the compataiblity patch that comes with Better Robes. but didn't have it installed on my latest playthrough because there was some issues with it. I'm assuming that's what needs to be updated?

And what about the Tel Darys issue? That very same issue is also present at Tel Aranyon. 

Rot's picture
Rot
Lead DeveloperQuest Developer
Joined:
2014-03-16 17:45
Last seen:
4 days 22 hours ago

Yes, it's only the patch, without it (or if it gets updated) you won't have those errors.
For the missing hallways, my guess would be that you have a mod for TR made with an older version (one that moves/deletes/edits an object in those cells; unfortunately when a new version is released those edits get pushed onto other objects, so minor items or architecture can end up moved or deleted). If so it will have to be updated with WryeMash (look for mods that are dependent on TR_Mainland). Another possibility could be if you've updated such a mod and reloaded a save, in which case it's the save that needs updating.

Atrayonis's picture
Atrayonis
Lead DeveloperDeveloperInterior Developer
Joined:
2015-09-28 20:13
Last seen:
7 hours 34 min ago

If your problems are related Tel Darys, Tel Aranyon and other related Telvanni towers, you are using an outdated version of Uvirith's Legacy. Please make sure you are using 3.51 and clean your save game as Rot said.

For Better Robes (TR Patch), I've gone and changed the paths and filepatched the esp. Since I don't use it myself, please check out if this corrects all the issues. If it does, I will upload it on MW Nexus for other people.

AttachmentSizeDate
File Better Robes TR Patch.7z579.77 KB2017-03-13 19:53
Kinky Kong Keith's picture
Kinky Kong Keith
Joined:
2017-03-12 18:24
Last seen:
4 months 5 days ago

I'll give that file a try. As for the towers, Uvirith's Legacy 3.51 is the first version I ever downloaded (I'm kinda new to this whole modding thing) but the TR addon is for TR 16.09. It didn't come with a 16.12 version. 

Rot's picture
Rot
Lead DeveloperQuest Developer
Joined:
2014-03-16 17:45
Last seen:
4 days 22 hours ago

You can try this for the missing hallways in Tel Darys (use instead of the TR addon that comes with UL, it's the same with an attempted update to 16.12),
Might not work in a savegame in which you've already visited Tel Darys:

AttachmentSizeDate
Package icon UL_3.5_TR_16.09.10_Add-on_16.12Update.esp.zip1.44 MB2017-03-14 17:13
Kinky Kong Keith's picture
Kinky Kong Keith
Joined:
2017-03-12 18:24
Last seen:
4 months 5 days ago

Guys, upload those patches to Nexus asap, cause that solved all the issues. 

Kinky Kong Keith's picture
Kinky Kong Keith
Joined:
2017-03-12 18:24
Last seen:
4 months 5 days ago

Ok, entirely new issue, that completely breaks the game. I decided to reinstall everything after issues with another mod (Vadul Tharis's Redoran Expansion to be exact). Well, I fired it up and this error pops up. 

Expression Error Unable to find cell id "Telvanni Library" in script TR_m2_TelvLib_NoTeleport

It crashes the game every time I try to start a new game. 

Rot's picture
Rot
Lead DeveloperQuest Developer
Joined:
2014-03-16 17:45
Last seen:
4 days 22 hours ago

"Telvanni Library": both the script and the cell are in the same file, so you must have another mod that loads afterwards and changes the name of the exterior. Mods that add islands/landmass where TR land is are incompatible unless they're moved elsewhere

Kinky Kong Keith's picture
Kinky Kong Keith
Joined:
2017-03-12 18:24
Last seen:
4 months 5 days ago

Here's my load order. Notice anything that conflicts with Tamriel rebuilt?

_001_ Morrowind.esm
_002_ Tribunal.esm
_003_ Bloodmoon.esm
_004_ Morrowind Patch v1.6.4.esm
_005_ Weapon Rotate.esm
_006_ Book Rotate.esm
_007_ GDR_MasterFile.esm
_008_ Beyond YsGramor v2.5.esm
_009_ BT_Whitewolf_2_0.esm
_010_ Rise of House Telvanni.esm
_011_ Tamriel_Data.esm
_012_ TR_Mainland.esm
_013_ Wyrmhaven.esm
_014_ Juniper's Twin Lamps (1.1 Tribunal).esp
_015_ LCV Schedule Markers.esp
_016_ NPC LCV Schedules 03.esp
_017_ AreaEffectArrows.esp
_018_ bcsounds.esp
_019_ master_index.esp
_020_ LeFemmArmor.esp
_021_ adamantiumarmor.esp
_022_ EBQ_Artifact.esp
_023_ LGNPC_NoLore.esp
_024_ Siege at Firemoth.esp
_025_ Haldenshore.esp
_026_ VOORHEES_AldIndoril2.esp
_027_ Indarys Unleashed.esp
_028_ Vivec's Fate.esp
_029_ NPC LCV Locks.esp
_030_ t_lostheir.esp
_031_ Book Rotate - Morrowind v1.1.esp
_032_ tusar_v1.2.1.esp
_033_ tusar_v1.2.1(bloodmoon addon).esp
_034_ Better Bodies.esp
_035_ The Imperial Legion Badge.esp
_036_ Creatures (lore).esp
_037_ Creatures Merged Objects Fix.esp
_038_ EEC Expansion.ESP
_039_ Less_Generic_Bloodmoon.esp
_040_ LGNPC_SeydaNeen.esp
_041_ LGNPC_GnaarMok_v1_20.esp
_042_ LGNPC_AldVelothi_v1_20.esp
_043_ Redoran_ExpansionRV1.1.esp
_044_ LGNPC_MaarGan.esp
_045_ LGNPC_HlaOad.esp
_046_ LGNPC_Aldruhn.esp
_047_ LGNPC_Aldruhn_suppl.esp
_048_ LGNPC_Pelagiad.esp
_049_ LGNPC_TelMora_v1_30.esp
_050_ LGNPC_Khuul_v2_21.esp
_051_ LGNPC_VivecFQ.esp
_052_ Less_Generic_Nerevarine.esp
_053_ LGNPC_TelUvirith.esp
_054_ LGNPC_SecretMasters_v1_30.esp
_055_ LGNPC_IndarysManor_v1_51.esp
_056_ LGNPC_VivecRedoran.esp
_057_ LGNPC_PaxRedoran_v1_20.esp
_058_ LGNPC_SoulSicknessPatch_v1_00.esp
_059_ Building Up Uvirith's Legacy1.1.ESP
_060_ South Wall.ESP
_061_ Illy's Solsteim Rumour Fix.esp
_062_ Morag Tong Expanded.esp
_063_ Reclaim Gnisis.ESP
_064_ Reclaim Gnisis - PAX Redoran patch.ESP
_065_ The Raven.esp
_066_ Note to Hrisskar.esp
_067_ Magical Missions.ESP
_068_ Hlaalu Business v1.0.esp
_069_ Passive_Healthy_Wildlife.esp
_070_ entertainers.esp
_071_ Better Morrowind Armor.esp
_072_ Better Morrowind Armor DeFemm(o).ESP
_073_ Better Robes.ESP
_074_ Grandmaster of Hlaalu 1.3.ESP
_075_ FatigueandMagickav1_1.ESP
_076_ optional- hand to hand levelling rebalance.esp
_077_ Uvirith's Legacy_3.51.esp
_078_ Less_Generic_Tribunal.esp
_079_ Better Robes TR.esp
_080_ Graphic Herbalism.esp
_081_ DB_Attack_Mod.esp
_082_ Camonna Tong.esp
_083_ UL_3.5_TR_16.09.10_Add-on_16.12Update.esp
_084_ UL_3.5_RoHT_1.52_Add-on.esp
_085_ Graphic Herbalism Tamriel_Data.esp
_086_ Graphic Herbalism Tamriel_Data Extra.esp
_087_ Great House Dagoth.esp
_088_ DN-GDRv1.1.esp
_089_ DNGDR-GHD Patch OV.esp
_090_ Great House Dagoth ( Master Index Compatibility ).esp
_091_ Creatures Great House Dagoth Patch.esp
_092_ KS_Julan_Ashlander Companion_2.0.esp
_093_ Better Clothes_v1.1.esp
_094_ SAC_Deserter_Legionaries.esp
_095_ CalderaFightClub.esp
_096_ Madd Leveler - Base.esp
_097_ Madd Leveler - Madd Skills.esp
_098_ Weapon Rotate - Tribunal.esp
_099_ Weapon Rotate - Bloodmoon.esp
_100_ Weapon Rotate - Vendors.esp
_101_ Fargoth's Hiding Place improvements 1.1.esp
_102_ Fort Frostmoth Restoration.esp
_103_ Book Rotate - Tribunal v5.3.esp
_104_ Book Rotate - Bloodmoon v5.3.esp
_105_ multipatch.esp

Rot's picture
Rot
Lead DeveloperQuest Developer
Joined:
2014-03-16 17:45
Last seen:
4 days 22 hours ago

Wouldn't know, but here's how you can find out: launch the games without TR loaded, go to an exterior, open up the console, type player->Position 230300 49600 5000 0 and see if that gets you somewhere: then with the console open click on the closest object you see and type ori enter, that should tell you which plugin puts something there.

MattBT123's picture
MattBT123
Joined:
2017-04-21 02:45
Last seen:
2 months 4 weeks ago

Bumping this thread because I'm getting the same error. I'm using only TR_Mainland on a fresh Morrowind install with the only other mods being MGE XE, better fonts and the Morrowind Code Patch. To summarise what I've done so far:

  • I've registered the PT_Data and TR_Data BSAs in the Morrowind .ini file. 
  • I've tried various things in Wrye Mash, but it has yet to detect any problems. 
  • I've regenerated distant land meshes and textures in MGE XE to verify that it wasn't causing the issue.
  • I've uninstalled and then reinstalled the Tamriel_Data and Tamriel Rebuilt mod files in the Morrowind directory, running Morrowind in between additions
  • I've been activating the mod files one at a time and then running Morrowind, to check that the issue wasn't in the Tamriel Rebuilt .esps

At this point I'm not sure what I can do short of straight-up reinstalling Morrowind, but I can't see that solving my problems.

Mortimer's picture
Mortimer
DeveloperQuest Developer
Joined:
2016-06-10 21:48
Last seen:
1 week 4 days ago

did you run mlox to sort your plugins
e: which error are you getting?

MattBT123's picture
MattBT123
Joined:
2017-04-21 02:45
Last seen:
2 months 4 weeks ago

My current load order according to mlox is this:
_001_ Morrowind.esm
_002_ Tribunal.esm
_003_ Bloodmoon.esm
_004_ Tamriel_Data.esm
_005_ TR_Mainland.esm
_006_ TR_Preview.esp
_007_ TR_Travels.esp

The errors I'm getting are various model load errors in the Meshes/TR directory, as well as animation errors on creatures.

Rot's picture
Rot
Lead DeveloperQuest Developer
Joined:
2014-03-16 17:45
Last seen:
4 days 22 hours ago

@MattBT123 Could it be something similar to above:

Sweet_Bro99

The tutorial outlines exactly what to write in (as you can see in my attachment above, it is correct). However, it says that [Archives] is located directly above the [Game Files], right at the bottom. If it is not located there, it says to then add it to that line (Or maybe I am crazy and hearing things). Anyway, that is what I did - but there is an [Archives] located elsewhere in the Morrowind.ini that was not getting updated (never thought to look).

ie is the [Archives] section near the bottom, and is there only one in the whole file?
 

MattBT123's picture
MattBT123
Joined:
2017-04-21 02:45
Last seen:
2 months 4 weeks ago

Tried that as well, but it didn't fix the issue for me.

Rot's picture
Rot
Lead DeveloperQuest Developer
Joined:
2014-03-16 17:45
Last seen:
4 days 22 hours ago

If with Windows UAC and not steam, have you tried installing outside of Program Files? You do have the correct load order.

Pages